Quantcast

MyBatis Java 6 Compatibility

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

MyBatis Java 6 Compatibility

vladimirala
Hi,

We are working on a code generator for MyBatis, and we wanted to maintain compatibility with Java 6. We noticed MyBatis versions 3.3.x are compatible with Java 6, but 3.4.x are not.

Do you know if is there any chance the latest versions could be compatible with Java 6?

Thank you.

PS: We are trying to keep compatibility with Java 6, since there are many installations that use it, mainly non-oracle JVM: read IBM, HP, and other JVMs. Java 6 is alive and kicking there, and fully supported til the end of time, probably.


--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MyBatis Java 6 Compatibility

Kazuki Shimizu
Probably MyBatis 3.4 can use on Java 6. But some feature added by 3.4 cannot use on Java 6.


On Thursday, January 5, 2017 at 1:26:47 AM UTC+9, [hidden email] wrote:
Hi,

We are working on a code generator for MyBatis, and we wanted to maintain compatibility with Java 6. We noticed MyBatis versions 3.3.x are compatible with Java 6, but 3.4.x are not.

Do you know if is there any chance the latest versions could be compatible with Java 6?

Thank you.

PS: We are trying to keep compatibility with Java 6, since there are many installations that use it, mainly non-oracle JVM: read IBM, HP, and other JVMs. Java 6 is alive and kicking there, and fully supported til the end of time, probably.


--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MyBatis Java 6 Compatibility

Kazuki Shimizu
Actually, The MyBatis 3.4 has been passed the build and test on Java 6, Java 7 and Java 8.

See https://travis-ci.org/mybatis/mybatis-3.


On Thursday, January 5, 2017 at 1:34:06 AM UTC+9, Kazuki Shimizu wrote:
Probably MyBatis 3.4 can use on Java 6. But some feature added by 3.4 cannot use on Java 6.


On Thursday, January 5, 2017 at 1:26:47 AM UTC+9, [hidden email] wrote:
Hi,

We are working on a code generator for MyBatis, and we wanted to maintain compatibility with Java 6. We noticed MyBatis versions 3.3.x are compatible with Java 6, but 3.4.x are not.

Do you know if is there any chance the latest versions could be compatible with Java 6?

Thank you.

PS: We are trying to keep compatibility with Java 6, since there are many installations that use it, mainly non-oracle JVM: read IBM, HP, and other JVMs. Java 6 is alive and kicking there, and fully supported til the end of time, probably.


--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Loading...