Generator Eclipse plugin not logging to console

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Generator Eclipse plugin not logging to console

rwfischer
I have not been successful to configure the Eclipse generator plugin to log to the Eclipse console.

When I run the generator from Eclipse, it shows a popup with info on the tasks the generator performs. However, when the generator completes, the popup vanishes. Nothing is logged to the console. Thus I am not able to see what was generated, or if there were any warnings.

I have tried the following without any impact:
  • Put the log4j.properties file form http://www.mybatis.org/generator/reference/logging.html into the project's root folder.
  • Put the same log4j.properties file into the same folder as the GerneratorConfig.xml file.
  • Add log4j-core.jar into the classpath of the run-configuration.
  • Add the project to the classpath in the run configuration.
  • All combinations of the above.
None of this seemed to affect the generator plugin.

Any other suggestions?

Thanks...

Roger

--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Generator Eclipse plugin not logging to console

Jeff Butler
I'll take a look at the logging problem.  I have made some changes to the plugin (not released yet) that should improve the situation - mainly by manipulating the classpath a little better and better use of the Eclipse console.  I would have thought that adding the project and the log4j jar to the run configuration classpath would work - so something must still be messed up with the classpath handling.

I'll report back on what I find.

Jeff Butler


On Tue, May 2, 2017 at 4:35 PM rwfischer <[hidden email]> wrote:
I have not been successful to configure the Eclipse generator plugin to log to the Eclipse console.

When I run the generator from Eclipse, it shows a popup with info on the tasks the generator performs. However, when the generator completes, the popup vanishes. Nothing is logged to the console. Thus I am not able to see what was generated, or if there were any warnings.

I have tried the following without any impact:
  • Put the log4j.properties file form http://www.mybatis.org/generator/reference/logging.html into the project's root folder.
  • Put the same log4j.properties file into the same folder as the GerneratorConfig.xml file.
  • Add log4j-core.jar into the classpath of the run-configuration.
  • Add the project to the classpath in the run configuration.
  • All combinations of the above.
None of this seemed to affect the generator plugin.

Any other suggestions?

Thanks...

Roger

--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Generator Eclipse plugin not logging to console

Jeff Butler
I don't think this can be made to work in the current version of the plugin unfortunately.  It has to do with the difficult way that Ant is shoehorned into eclipse.

I can get it to work with the changes I've already made for the next release, but it is still a bit of a chore.  I'm going to try to make it easier before I release the next version.

Jeff Butler



On Wed, May 3, 2017 at 8:02 AM Jeff Butler <[hidden email]> wrote:
I'll take a look at the logging problem.  I have made some changes to the plugin (not released yet) that should improve the situation - mainly by manipulating the classpath a little better and better use of the Eclipse console.  I would have thought that adding the project and the log4j jar to the run configuration classpath would work - so something must still be messed up with the classpath handling.

I'll report back on what I find.

Jeff Butler


On Tue, May 2, 2017 at 4:35 PM rwfischer <[hidden email]> wrote:
I have not been successful to configure the Eclipse generator plugin to log to the Eclipse console.

When I run the generator from Eclipse, it shows a popup with info on the tasks the generator performs. However, when the generator completes, the popup vanishes. Nothing is logged to the console. Thus I am not able to see what was generated, or if there were any warnings.

I have tried the following without any impact:
  • Put the log4j.properties file form http://www.mybatis.org/generator/reference/logging.html into the project's root folder.
  • Put the same log4j.properties file into the same folder as the GerneratorConfig.xml file.
  • Add log4j-core.jar into the classpath of the run-configuration.
  • Add the project to the classpath in the run configuration.
  • All combinations of the above.
None of this seemed to affect the generator plugin.

Any other suggestions?

Thanks...

Roger

--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Generator Eclipse plugin not logging to console

rwfischer
Thanks, Jeff. I will revisit this after the next release is out.

Roger

--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Generator Eclipse plugin not logging to console

Jeff Butler
I've created an issue to track this:  https://github.com/mybatis/generator/issues/224

I've made some progress, but there's a bit more to do.

Jeff Butler



On Fri, May 5, 2017 at 5:02 PM rwfischer <[hidden email]> wrote:
Thanks, Jeff. I will revisit this after the next release is out.

Roger

--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "mybatis-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Loading...